Nord's classical Virtual Analog Synth Nord LEAD 1/2/2x/3/4/A1 and Nord Rack versions

NORD LEAD 2 (not 2X) power supply question

Postby isakeliyahu » 08 May 2020, 14:57

EDIT: i just found out i was mistaking cause of lack of concentration, the regulator is LM2940 not LM3940 which is fine, sorry to bother anyone.

cheers.

Hi Guys.

new user here :)
i got nord lead 2 as a gift from a frien, i have some issues with it.
when turning it on it wont boot up, so i open the NL and sniff around, after soldering few areas that looks suspicious it turn on but not at first time, i need to turn it on wait a bit, turn it off, and turn it on again, after a sec the NL is turn on and working.
so it seems to me like a an electrolytic cap problem to me.
ive tested the power supply board and this is what ive found..
i think i found a flaw in the power supply section, the main power brick is outputting 4x 6V outputs 5.5A for each output,
each output goes to a diodes and regulators that gives +12V, -12V, +3.3V and -5V.
the regulator of the +3.3V is LM3940 which according to the datasheet, the max V in is between 4.5V to 5.5V, when measuring with multi i read 7.4V at the input and 4.95V at the output.
from the power brick, it goes directly to 4,700uF for filtering and from there to the LM3940 regulator.
i'm thinking to my self, why they used the 6V output power brick while the real output is 7.4V and the max V in of LM3940 is 5.5 when it should be 3.3V?
if they needed to use 5V instead of 3.3V why not to use 7805 instead?
isnt this a flaw?
what do you think?

cheers,
Isak.
Last edited by isakeliyahu on 08 May 2020, 15:16, edited 1 time in total.
isakeliyahu
 
Posts: 1
Joined: 08 May 2020, 14:45
Country: Israel
Has thanked: 0 time
Been thanked: 0 time
Your Nord Gear #1: Nord Lead 1/2/2x

NORD LEAD 2 (not 2X) power supply question


Sponsor
 

Return to Nord Lead / Rack Forum



Who is online

Users browsing this forum: No registered users and 0 guests