Nord's classical Virtual Analog Synth Nord LEAD 1/2/2x/3/4/A1 and Nord Rack versions

Lead 2x - Portamento Potentiometer Problem

Postby Pjngu » 29 Aug 2018, 19:01

Hi everyone!

I have a Lead 2x and I have a problem with the Portamento Potentiometer: in particular, when I use it, the sound parameters are changed randomally ( octave, noise amount and more). How can I fix it? :sad: :sad:
Pjngu
 
Posts: 1
Joined: 29 Aug 2018, 18:52
Country: Italy
Has thanked: 0 time
Been thanked: 0 time
Your Nord Gear #1: Nord Lead 1/2/2x
Your Nord Gear #2: Nord Electro 3

Lead 2x - Portamento Potentiometer Problem


Sponsor
 

Re: Lead 2x - Portamento Potentiometer Problem

Postby Mr_-G- » 29 Aug 2018, 19:38

I can think of 3 options: "clean" the pot with some spray product for that purpose (if you know how to do it), change the pot/encoder yourself (if you are sure it is that what is faulty) or you send it to a service. I doubt that there is a "software" fix for that.
User avatar
Mr_-G-
Moderator
 
Posts: 3894
Joined: 18 Aug 2012, 16:48
Has thanked: 1110 times
Been thanked: 1029 times
Your Nord Gear #1: Nord Stage 2

Re: Lead 2x - Portamento Potentiometer Problem

Postby Ledbetter » 01 Sep 2018, 02:29

Unless you know what you’re doing, take it to a certified tech and have the pot replaced. Talk to a Nord rep for your geographical area.

You have to take the synth apart to get the contact cleaner to the location that need cleaning. Cleaning a pot with contact cleaner is not a sure fix. Good luck, best wishes.
Nord Electro 5D, 4D, Lead 2x, Moog Voyager, Little and Slim Phatties, Kawai KG-2C 6 foot grand,
Ledbetter
Donator
 
Posts: 292
Joined: 05 Jul 2013, 03:31
Country: United States of America
Has thanked: 59 times
Been thanked: 69 times
Your Nord Gear #1: Nord Electro 5
Your Nord Gear #2: Nord Lead 1/2/2x

Re: Lead 2x - Portamento Potentiometer Problem

Postby wartaler » 16 May 2020, 23:56

Hi,
I know this is a very old thread, but I have a similar, if not exactly the same problem, so I was wondering if & how the NL2x in above post was fixed, if other people experienced something similar,..

When I turn the Portmento knob, sometimes one or two other parameters jump to another value, I checked with a MIDI monitor app and it's not just random values in my case, it's the value that corresponds with the physical position of the other knob(s), so if the OSC2 octave knob is at position 0 (CC value 60) OSC2 octave will go to that value if it wasn't already. What does seem to be random is which other parameters, but I think in most cases it's from a knob that was recently used, and sort of 'in between values', but sometimes I even see a pitch-bend message pop up, which isn't even a pot.

I'm not sure if the pots are dirty or whatever is reading the pot values (multiplexer?) is messed up:
-After monitoring MIDI for hours while not touching the NL2x, no spontaneous MIDI messages were detected.
-All knobs seem to work fine, they smoothly go from CC value 0 to 127 (or whatever range is used for the parameter) and back without jumps or glitches, including the portamento knob.
-Turning the portamento knob (usually below CC value=1) somehow seems to trigger a readout of the actual position of other knob(s)
-Also pressing the LFO1 wave select and Arp on/off buttons can trigger this
-Sometimes I even see pitch-bend messages appear, which I think isn't even a pot

I cleaned all pots and still get this behavior..


Albert
Last edited by wartaler on 22 May 2020, 15:45, edited 15 times in total.
Nord Drum 2, Drum (1), Lead 2x, Stage 'Classic', Micro Modular
wartaler
Moderator
 
Posts: 603
Joined: 19 Mar 2009, 18:32
Country: Netherlands
Has thanked: 68 times
Been thanked: 196 times
Your Nord Gear #1: Nord Stage Classic
Your Nord Gear #2: Nord Drum 2


Return to Nord Lead / Rack Forum



Who is online

Users browsing this forum: No registered users and 0 guests