Nord's classical Virtual Analog Synth Nord LEAD 1/2/2x/3/4/A1 and Nord Rack versions

NL2 Dead/Dying outputs :(

Postby Nuyorican » 30 Apr 2018, 20:54

First off,

Hello everyone! Never knew there was a Nord forum until I had a problem to fix.

Well, my beloved Nord Lead 2 is not very well. The outputs seem to be on their way out. I bought it second-hand a few years ago, and from then, outputs B,C and D never worked. I stupidly didn't check it properly and just plugged in a mono cable to output A to test it. It was only much later when I tried to activate the other outputs that I realised they didn't work. Much too late to bring it up with the seller unfortunately.

So, hey ho, I've been using it as a mono-synth all this time. But now output A is starting to go. It'll just randomly go quiet (you can hear it very faintly if you turn up the amp.

Any ideas? Anything I can do?

Thanks!
Nuyorican
 
Posts: 1
Joined: 30 Apr 2018, 20:44
Country: Great Britain
Has thanked: 0 time
Been thanked: 0 time
Your Nord Gear #1: Nord Lead 1/2/2x

NL2 Dead/Dying outputs :(


Sponsor
 

Re: NL2 Dead/Dying outputs :(

Postby Mr_-G- » 30 Apr 2018, 21:47

Does it work if you move the plug around? I wonder if it might be some oxide in the jack connector.
User avatar
Mr_-G-
Moderator
 
Posts: 3319
Joined: 18 Aug 2012, 16:48
Has thanked: 937 times
Been thanked: 875 times
Your Nord Gear #1: Nord Stage 2


Return to Nord Lead / Rack Forum



Who is online

Users browsing this forum: No registered users and 1 guest